Deprecated: mysql_connect(): The mysql extension is deprecated...

В данный момент, по умолчанию все новые аккаунты hostinger используют версию php 5.5. На некоторых движках сайтов, данная версия поддерживается только в самых свежих версиях.

Вы можете получать подобную ошибку : Deprecated: mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead in /home/u231355116/public_html/lib/common.php on line 21

Исправить данную ошибку очень легко. Вам нужно в аккаунте изменить версию PHP на 5.3. Для этого, войдите в аккаунт -> прокрутите панель управления к разделу Дополнительно -> Выбор PHP версии. После этого переключите чекбокс на версию 5.3 и нажмите сохранить.

Как правило, после проделанной процедуры, ошибка исчезает.


Статьи по теме: